Cloudflare Wrangler directory traversal vulnerability
### Impact The Wrangler command line tool (<=wrangler@3.1.0 or <=wrangler@2.20.1) was affected by a directory traversal vulnerability when running a local development server for Pages (wrangler pages dev command). This vulnerability enabled an attacker in the same network as the victim to connect to the local development server and access the victim's files present outside of the directory for the development server. ### Patches Wrangler2: Upgrade to v2.20.1 or higher. Wrangler3: Upgrade to v3.1.1 or higher. ### References [Workers SDK on Github](https://github.com/cloudflare/workers-sdk) [Wrangler docs](https://developers.cloudflare.com/workers/wrangler/) [CVE-2023-3348](https://www.cve.org/CVERecord?id=CVE-2023-3348)
beschreibt (1)
Zugehörige CVEs.
| ID | Schweregrad | ausnutzbar | ||
|---|---|---|---|---|
| CVE-2023-3348US | medium5.7 | — | ||
The Wrangler command line tool (<=wrangler@3.1.0 or <=wrangler@2.20.1) was affected by a directory traversal vulnerability when running a local development server for Pages (wrang… | ||||
Referenzen
Externe Belege — Patches, Meldungen, Analysen.
- https://developers.cloudflare.com/workers/wranglerWEB
- https://github.com/cloudflare/workers-sdkPACKAGE
- https://github.com/cloudflare/workers-sdk/commit/fddffdf0c23d2ca56f2139a2c6bc278052594cbaWEB
- https://github.com/cloudflare/workers-sdk/pull/3498WEB
- https://github.com/cloudflare/workers-sdk/releases/tag/wrangler%403.1.1WEB
- https://github.com/cloudflare/workers-sdk/security/advisories/GHSA-8c93-4hch-xgxpWEB
- https://nvd.nist.gov/vuln/detail/CVE-2023-3348ADVISORY
Advisories wie diese benennen die exponierten Produkte, die Angreifer auf Ihrer Angriffsfläche ins Visier nehmen. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan