GHSA-gw5h-h6hj-f56g

ghsaUSosv

Gogs vulnerable to improper PAM authorization handling

Advisory ansehen veröffentlicht 2022-03-14Lizenz: CC-BY-4.0

### Impact Expired PAM accounts and accounts with expired passwords are continued to be seen as valid. Installations use PAM as authentication sources are affected. ### Patches Expired PAM accounts and accounts with expired passwords are no longer being seen as valid. Users should upgrade to 0.12.5 or the latest 0.13.0+dev. ### Workarounds In addition to marking PAM accounts as expired, also disable/lock them. Running `usermod -L <username>` will add an exclamation mark to the password hash and would result in wrong passwords responses when trying to login. ### References https://huntr.dev/bounties/ea82cfc9-b55c-41fe-ae58-0d0e0bd7ab62/ ### For more information If you have any questions or comments about this advisory, please post on https://github.com/gogs/gogs/issues/6810.

01

beschreibt (1)

Zugehörige CVEs.

IDSchweregrad ausnutzbar
CVE-2022-0871UScritical9.1OT erhöht—
Missing Authorization in GitHub repository gogs/gogs prior to 0.12.5.
02

Referenzen

Externe Belege — Patches, Meldungen, Analysen.

scry

Advisories wie diese benennen die exponierten Produkte, die Angreifer auf Ihrer Angriffsfläche ins Visier nehmen. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.

Kostenloser Scan