GHSA-p9m8-27x8-rg87

ghsaUSosv

Critical vulnerability found in cron-utils

Advisory ansehen veröffentlicht 2021-11-15Lizenz: CC-BY-4.0

### Impact A Template Injection was identified in cron-utils enabling attackers to inject arbitrary Java EL expressions, leading to unauthenticated Remote Code Execution (RCE) vulnerability. Versions up to 9.1.2 are susceptible to this vulnerability. Please note, that only projects using the @Cron annotation to validate untrusted Cron expressions are affected. ### Patches The issue was patched and a new version was released. Please upgrade to version 9.1.6. ### Workarounds There are no known workarounds up to this moment. ### References A description of the issue is provided in [issue 461](https://github.com/jmrozanec/cron-utils/issues/461) ### For more information If you have any questions or comments about this advisory: Open an issue in the [cron-utils Github repository](https://github.com/jmrozanec/cron-utils)

01

beschreibt (1)

Zugehörige CVEs.

IDSchweregrad ausnutzbar
CVE-2021-41269UScritical9.8Exploit
cron-utils is a Java library to define, parse, validate, migrate crons as well as get human readable descriptions for them. In affected versions A template Injection was identified…
02

Referenzen

Externe Belege — Patches, Meldungen, Analysen.

scry

Advisories wie diese benennen die exponierten Produkte, die Angreifer auf Ihrer Angriffsfläche ins Visier nehmen. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.

Kostenloser Scan