Use-After-Free in puppeteer
Versions of `puppeteer` prior to 1.13.0 are vulnerable to the Use-After-Free vulnerability in Chromium (CVE-2019-5786). The Chromium FileReader API is vulnerable to Use-After-Free which may lead to Remote Code Execution. ## Recommendation Upgrade to version 1.13.0 or later.
01
beschreibt (1)
Zugehörige CVEs.
| ID | Schweregrad | ausnutzbar | ||
|---|---|---|---|---|
| CVE-2019-5786US | medium6.5OT kritisch | KEV | ||
Object lifetime issue in Blink in Google Chrome prior to 72.0.3626.121 allowed a remote attacker to potentially perform out of bounds memory access via a crafted HTML page. | ||||
02
Referenzen
Externe Belege — Patches, Meldungen, Analysen.
- https://blog.exodusintel.com/2019/03/20/cve-2019-5786-analysis-and-exploitationWEB
- https://chromereleases.googleblog.com/2019/03/stable-channel-update-for-desktop.htmlWEB
- https://crbug.com/936448WEB
- https://github.com/GoogleChrome/puppeteerPACKAGE
- https://github.com/GoogleChrome/puppeteer/issues/4141WEB
- https://nvd.nist.gov/vuln/detail/CVE-2019-5786ADVISORY
- https://snyk.io/vuln/SNYK-JS-PUPPETEER-174321WEB
- https://www.npmjs.com/advisories/824WEB
scry
Advisories wie diese benennen die exponierten Produkte, die Angreifer auf Ihrer Angriffsfläche ins Visier nehmen. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan