Jenkins HTML Publisher Plugin vulnerable to Cross-site Scripting
Jenkins HTML Publisher Plugin prior to version 1.21 did not escape the project and build display names in the HTML report frame, resulting in a cross-site scripting vulnerability exploitable by users able to change those. This issue has been patched in version 1.21
01
beschreibt (1)
Zugehörige CVEs.
| ID | Schweregrad | ausnutzbar | ||
|---|---|---|---|---|
| CVE-2019-10432US | medium5.4 | — | ||
Jenkins HTML Publisher Plugin 1.20 and earlier did not escape the project and build display names in the HTML report frame, resulting in a cross-site scripting vulnerability exploi… | ||||
02
Referenzen
Externe Belege — Patches, Meldungen, Analysen.
- http://www.openwall.com/lists/oss-security/2019/10/01/2WEB
- https://access.redhat.com/errata/RHSA-2019:4055WEB
- https://access.redhat.com/errata/RHSA-2019:4089WEB
- https://access.redhat.com/errata/RHSA-2019:4097WEB
- https://github.com/jenkinsci/htmlpublisher-pluginPACKAGE
- https://github.com/jenkinsci/htmlpublisher-plugin/commit/637aad0308f8cdfb24610041fcfe815d5a1a096bWEB
- https://github.com/jenkinsci/htmlpublisher-plugin/releases/tag/htmlpublisher-1.21WEB
- https://jenkins.io/security/advisory/2019-10-01/#SECURITY-1590WEB
scry
Advisories wie diese benennen die exponierten Produkte, die Angreifer auf Ihrer Angriffsfläche ins Visier nehmen. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan