RubyGems Link Following vulnerability
RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in `install_location` function of `package.rb` that can result in path traversal when writing to a symlinked basedir outside of the root. This vulnerability appears to have been fixed in 2.7.6.
01
beschreibt (1)
Zugehörige CVEs.
| ID | Schweregrad | ausnutzbar | ||
|---|---|---|---|---|
| CVE-2018-1000073US | high7.5 | — | ||
RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revi… | ||||
02
Referenzen
Externe Belege — Patches, Meldungen, Analysen.
- http://blog.rubygems.org/2018/02/15/2.7.6-released.htmlWEB
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00036.htmlWEB
- https://access.redhat.com/errata/RHSA-2018:3729WEB
- https://access.redhat.com/errata/RHSA-2018:3730WEB
- https://access.redhat.com/errata/RHSA-2018:3731WEB
- https://access.redhat.com/errata/RHSA-2019:2028WEB
- https://access.redhat.com/errata/RHSA-2020:0542WEB
- https://access.redhat.com/errata/RHSA-2020:0591WEB
scry
Advisories wie diese benennen die exponierten Produkte, die Angreifer auf Ihrer Angriffsfläche ins Visier nehmen. Sehen Sie mit einem kostenlosen Passiv-Scan, was exponiert ist.
Kostenloser Scan