ruby4.0-rubygem-puma-6.4.3-1.5 on GA media
ruby4.0-rubygem-puma-6.4.3-1.5 on GA media
describes (4)
Related CVEs.
| ID | severity | exploitable | ||
|---|---|---|---|---|
| CVE-2024-45614US | medium5.4 | Exploit | ||
Puma is a Ruby/Rack web server built for parallelism. In affected versions clients could clobber values set by intermediate proxies (such as X-Forwarded-For) by providing a undersc… | ||||
| CVE-2022-23634US | medium5.9 | — | ||
Puma is a Ruby/Rack web server built for parallelism. Prior to `puma` version `5.6.2`, `puma` may not always call `close` on the response body. Rails, prior to version `7.0.2.2`, d… | ||||
| CVE-2020-11076US | high7.5 | Exploit | ||
In Puma (RubyGem) before 4.3.4 and 3.12.5, an attacker could smuggle an HTTP response, by using an invalid transfer-encoding header. The problem has been fixed in Puma 3.12.5 and P… | ||||
| CVE-2019-16770US | high7.5 | — | ||
In Puma before versions 3.12.2 and 4.3.1, a poorly-behaved client could use keepalive requests to monopolize Puma's reactor and create a denial of service attack. If more keepalive… | ||||
references
External citations — patches, advisories, analysis.
remediations (16)
- Fixedruby4.0-rubygem-puma-0:6.4.3-1.5.aarch64 as component of openSUSE Tumbleweed
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedruby4.0-rubygem-puma-0:6.4.3-1.5.aarch64 as component of openSUSE Tumbleweed
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedruby4.0-rubygem-puma-0:6.4.3-1.5.aarch64 as component of openSUSE Tumbleweed
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedruby4.0-rubygem-puma-0:6.4.3-1.5.aarch64 as component of openSUSE Tumbleweed
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedruby4.0-rubygem-puma-0:6.4.3-1.5.ppc64le as component of openSUSE Tumbleweed
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedruby4.0-rubygem-puma-0:6.4.3-1.5.ppc64le as component of openSUSE Tumbleweed
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedruby4.0-rubygem-puma-0:6.4.3-1.5.ppc64le as component of openSUSE Tumbleweed
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedruby4.0-rubygem-puma-0:6.4.3-1.5.ppc64le as component of openSUSE Tumbleweed
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedruby4.0-rubygem-puma-0:6.4.3-1.5.s390x as component of openSUSE Tumbleweed
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedruby4.0-rubygem-puma-0:6.4.3-1.5.s390x as component of openSUSE Tumbleweed
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedruby4.0-rubygem-puma-0:6.4.3-1.5.s390x as component of openSUSE Tumbleweed
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedruby4.0-rubygem-puma-0:6.4.3-1.5.s390x as component of openSUSE Tumbleweed
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedruby4.0-rubygem-puma-0:6.4.3-1.5.x86_64 as component of openSUSE Tumbleweed
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedruby4.0-rubygem-puma-0:6.4.3-1.5.x86_64 as component of openSUSE Tumbleweed
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedruby4.0-rubygem-puma-0:6.4.3-1.5.x86_64 as component of openSUSE Tumbleweed
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedruby4.0-rubygem-puma-0:6.4.3-1.5.x86_64 as component of openSUSE Tumbleweed
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.
Free scan