VDE-2021-011

csafDEtrumpf_psirt

TRUMPF Laser GmbH: TruControl 2.14.0 to 3.14.0 affected by recent sudo vulnerability

view advisory published 2021-03-22

TruControl laser control software from versions 2.14.0 to 3.14.0 use sudo versions affected by CVE-2021-3156. The affected sudo has a heap-based buffer overflow, allowing privilege escalation to root via "sudoedit -s" and a command-line argument that ends with a single backslash character.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2021-3156UShigh7.8OT criticalKEV
Sudo before 1.9.5p2 contains an off-by-one error that can result in a heap-based buffer overflow, which allows privilege escalation to root via "sudoedit -s" and a command-line arg…
02

references

External citations — patches, advisories, analysis.

03

remediations (1)

  • Fixed

    - Update to TruControl version 3.16.0 or higher or - Please contact your service partner (service.tls@trumpf.com) for instructions on how to retrieve the patch

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan