VDE-2025-098

csafDEbaade_m2m_psirt

Baade M2M-Products GmbH: ubusd heap buffer overflow vulnerability in OpenWRT prior to version 24.10.4

view advisory published 2026-04-02

OpenWrt Project is a Linux operating system targeting embedded devices. Prior to version 24.10.4, ubusd contains a heap buffer overflow in the event registration parsing code. This allows an attacker to modify the head and potentially execute arbitrary code in the context of the ubus daemon. The affected code is executed before running the ACL checks, all ubus clients are able to send such messages. In addition to the heap corruption, the crafted subscription also results in a bypass of the listen ACL.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2025-62526UShigh7.8—
OpenWrt Project is a Linux operating system targeting embedded devices. Prior to version 24.10.4, ubusd contains a heap buffer overflow in the event registration parsing code. This…
02

references

External citations — patches, advisories, analysis.

03

remediations (2)

  • FixedFirmware 3.22 installed with Baade Linux <4.65 on TCP/IP-Web-Connector 1xCOM since 2018

    Baade M2M-Products GmbH recommends to upgrade the Baade Linux OS version of our Products TCP/IP-Web-Connector 1xCOM (since 2018) and TCP/IP-Web-Connector 4xCOM to version 4.65 or later to fix the ubusd security vulnerability.

  • FixedFirmware 3.22 installed with Baade Linux <4.65 on TCP/IP-Web-Connector 4xCOM

    Baade M2M-Products GmbH recommends to upgrade the Baade Linux OS version of our Products TCP/IP-Web-Connector 1xCOM (since 2018) and TCP/IP-Web-Connector 4xCOM to version 4.65 or later to fix the ubusd security vulnerability.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan