GHSA-r9v2-gg2j-22q5

ghsaUSosv

Payload: Insufficient Access Control in Stripe REST Proxy

view advisory published 2026-10-06Licence: CC-BY-4.0

## Impact An authenticated user could perform unintended Stripe operations through the optional Stripe REST proxy. **You are affected if ALL of these are true:** - Your application uses `@payloadcms/plugin-stripe`. - The optional Stripe REST proxy is enabled. - An authenticated user can reach the proxy. Deployments that do not enable the Stripe REST proxy are not affected. ## Patches Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`. ## Workarounds Upgrading to a patched version is recommended. If you cannot upgrade immediately, disable the Stripe REST proxy. If it must remain enabled, restrict access to trusted users and only the required Stripe operations.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2026-105848UScritical9.6OT elevated—
Payload is a free and open source headless content management system. In @payloadcms/plugin-stripe versions before 3.90.0 and canary versions before 4.0.0-canary.34, an authenticat…
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan