Apache Tomcat's FORM authentication process has an Incorrect Authorization vulnerability
Incorrect Authorization vulnerability in Apache Tomcat's FORM authentication process allows the bypassing of a security constraint that limits user has access to a resource POST but not GET. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fixes the issue.
describes (1)
Related CVEs.
| ID | severity | exploitable | ||
|---|---|---|---|---|
| CVE-2026-68525US | —OT elevated | — | ||
Incorrect Authorization vulnerability in Apache Tomcat's FORM authentication process allows the bypassing of a security constraint that limits user has access to a resource POST bu… | ||||
references
External citations — patches, advisories, analysis.
- http://www.openwall.com/lists/oss-security/2026/08/26/7WEB
- https://github.com/apache/tomcatPACKAGE
- https://github.com/apache/tomcat/commit/10d048e16034ddf12055e0cede0da05b15c823b8WEB
- https://github.com/apache/tomcat/commit/32f0c38526b4e655ff0c17cd97afedefc624fe43WEB
- https://github.com/apache/tomcat/commit/58123aa468a20e2a079b7e0c68a4009e2475c098WEB
- https://lists.apache.org/thread/x1y2lfsgzxwzc456f8954vbvgn03zhd7WEB
- https://nvd.nist.gov/vuln/detail/CVE-2026-68525ADVISORY
- https://tomcat.apache.org/security-10.htmlWEB
Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.
Free scan