GHSA-hh8r-75r6-qrg9

ghsaUSosv

Apache Camel-Langchain4j-Tools: Tool argument headers are not filtered against declared parameters

view advisory published 2026-07-06Licence: CC-BY-4.0

Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.18.3, 4.21.0, which fixes the issue.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2026-49042US—Exploit
Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade…
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan