GHSA-c2rv-hwqm-wjpg

ghsaUSosv

Apache Calcite is Vulnerable to Use of Externally-Controlled Input to Select Classes

view advisory published 2026-06-02Licence: CC-BY-4.0

Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Calcite. This issue affects Apache Calcite: from 1.5.0 before 1.42. Users are recommended to upgrade to version 1.42, which fixes the issue.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2026-46718US——
Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Calcite. This issue affects Apache Calcite: from 1.5.0 before 1.42. Use…
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan