Apache Tomcat - Security constraints not correctly applied
Versions Affected: Apache Tomcat 11.0.0-M1 to 11.0.21 Apache Tomcat 10.1.0-M1 to 10.1.54 Apache Tomcat 9.0.0.M1 to 9.0.117 Older, unsupported versions may also be affected Description: When multiple security constraints defined an HTTP method constraint for the same extension pattern, only the first method constraint was applied. Mitigation: Users of the affected versions should apply one of the following mitigations: - Upgrade to Apache Tomcat 11.0.22 or later - Upgrade to Apache Tomcat 10.1.55 or later - Upgrade to Apache Tomcat 9.0.118 or later
describes (1)
Related CVEs.
| ID | severity | exploitable | ||
|---|---|---|---|---|
| CVE-2026-43515US | — | Exploit | ||
Improper Authorization vulnerability when multiple method constraints define an HTTP method for the same extension in Apache Tomcat.
This issue affects Apache Tomcat: from 11.0.0-… | ||||
references
External citations — patches, advisories, analysis.
- http://www.openwall.com/lists/oss-security/2026/05/12/11WEB
- https://github.com/apache/tomcatPACKAGE
- https://github.com/apache/tomcat/commit/276087d9c7abbcecc6c4fb4e4b08cf64780c6e36WEB
- https://github.com/apache/tomcat/commit/c621317382682206fb58ab92ebd3e1b6fdd10ce9WEB
- https://github.com/apache/tomcat/commit/db919ff9912b4d61d1b702a1342b8bde39270031WEB
- https://lists.apache.org/thread/746nxfxod0wsocxtmv8pb8nkgmwpc6bbWEB
- https://nvd.nist.gov/vuln/detail/CVE-2026-43515ADVISORY
- https://tomcat.apache.org/security-10.htmlWEB
Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.
Free scan