Apache HTTP Server: mod_xml2enc heap overflow
Heap-based Buffer Overflow vulnerability in Apache HTTP Server with mod_xml2enc, xml2StartParse, and untrusted content This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
01
describes (1)
Related CVEs.
| ID | severity | exploitable | ||
|---|---|---|---|---|
| CVE-2026-42536US | — | Exploit | ||
Heap-based Buffer Overflow vulnerability in Apache HTTP Server with mod_xml2enc, xml2StartParse, and untrusted content
This issue affects Apache HTTP Server: from 2.4.0 through 2.… | ||||
02
references
External citations — patches, advisories, analysis.
- http://www.openwall.com/lists/oss-security/2026/06/08/9ADVISORY
- https://access.redhat.com/errata/RHSA-2026:25042WEB
- https://access.redhat.com/errata/RHSA-2026:34109WEB
- https://access.redhat.com/errata/RHSA-2026:41906WEB
- https://access.redhat.com/errata/RHSA-2026:42828WEB
- https://access.redhat.com/errata/RHSA-2026:47046WEB
- https://access.redhat.com/errata/RHSA-2026:53371WEB
- https://access.redhat.com/errata/RHSA-2026:56868WEB
scry
Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.
Free scan