GHSA-gg9v-mgcp-v6m7

ghsaUSosv

OpenClaw: Unbound bootstrap setup codes allow privilege escalation during pairing

view advisory published 2026-04-03Licence: CC-BY-4.0

## Summary Bootstrap setup codes were not bound to the intended device role and scopes, allowing first-use privilege escalation during pairing. ## Current Maintainer Triage - Status: open - Normalized severity: high - Assessment: Real first-use bootstrap privilege-escalation bug fixed and shipped in v2026.3.22+, so keep open for publication with current severity. ## Affected Packages / Versions - Package: `openclaw` (npm) - Latest published npm version: `2026.3.31` - Vulnerable version range: `<=2026.3.13-1` - Patched versions: `>= 2026.3.22` - First stable tag containing the fix: `v2026.3.22` ## Fix Commit(s) - `a600c72ed7d0045a27f58bf031d2b36ecb0141c9` — 2026-03-22T23:57:15-07:00 OpenClaw thanks @tdjackey for reporting.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2026-41386UScritical9.8—
OpenClaw before 2026.3.22 contains a privilege escalation vulnerability where bootstrap setup codes are not bound to intended device roles and scopes during pairing. Attackers can…
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan