GHSA-3qpv-xf3v-mm45

ghsaUSosv

OpenClaw: Workspace `.env` can override the bundled hooks root and load attacker hook code

view advisory published 2026-04-02Licence: CC-BY-4.0

## Summary Workspace `.env` can override the bundled hooks root and load attacker hook code ## Current Maintainer Triage - Status: open - Normalized severity: high - Assessment: v2026.3.28 still lets workspace .env override OPENCLAW_BUNDLED_HOOKS_DIR, which can replace trusted default-on bundled hooks from an untrusted workspace. ## Affected Packages / Versions - Package: `openclaw` (npm) - Latest published npm version: `2026.3.31` - Vulnerable version range: `<=2026.3.28` - Patched versions: `>= 2026.3.31` - First stable tag containing the fix: `v2026.3.31` ## Fix Commit(s) - `330a9f98cb29c79b1c16a2117e03d6276a0d6289` — 2026-03-31T19:25:12+09:00 OpenClaw thanks @nexrin for reporting.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2026-41336US——
OpenClaw before 2026.3.31 allows workspace .env files to override the OPENCLAW_BUNDLED_HOOKS_DIR environment variable, enabling loading of attacker-controlled hook code. Attackers…
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan