GHSA-mwf2-qr4v-94h2

ghsaUSosv

Apache Superset: Read-Only Bypass via Improper Input Validation on PostgreSQL Connections

view advisory published 2026-02-24Licence: CC-BY-4.0

An Improper Input Validation vulnerability exists in Apache Superset that allows an authenticated user with SQLLab access to bypass the read-only verification check when using a PostgreSQL database connection. While the system effectively blocks standard Data Manipulation Language (DML) statements (e.g., INSERT, UPDATE, DELETE) on read-only connections, it fails to detect them in specially crafted SQL statements. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2026-23984USmedium6.5OT elevated—
An Improper Input Validation vulnerability exists in Apache Superset that allows an authenticated user with SQLLab access to bypass the read-only verification check when using a Po…
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan