GHSA-mhpq-m962-mg92

ghsaUSosv

Apache Superset allows authenticated users to discover metadata about datasources they don't have permission to access

view advisory published 2025-08-14Licence: CC-BY-4.0

Apache Superset contains an improper access control vulnerability in its /explore endpoint. A missing authorization check allows an authenticated user to discover metadata about datasources they do not have permission to access. By iterating through the datasource_id in the URL, an attacker can enumerate and confirm the existence and names of protected datasources, leading to sensitive information disclosure. This issue affects Apache Superset: before 5.0.0. Users are recommended to upgrade to version 5.0.0, which fixes the issue.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2025-55675USmedium6.5—
Apache Superset contains an improper access control vulnerability in its /explore endpoint. A missing authorization check allows an authenticated user to discover metadata about da…
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan