Apache Commons Lang is vulnerable to Uncontrolled Recursion when processing long inputs
Uncontrolled Recursion vulnerability in Apache Commons Lang. This issue affects Apache Commons Lang: Starting with commons-lang:commons-lang 2.0 to 2.6, and, from org.apache.commons:commons-lang3 3.0 before 3.18.0. The methods ClassUtils.getClass(...) can throw StackOverflowError on very long inputs. Because an Error is usually not handled by applications and libraries, a StackOverflowError could cause an application to stop. Users are recommended to upgrade to version 3.18.0, which fixes the issue.
describes (1)
Related CVEs.
| ID | severity | exploitable | ||
|---|---|---|---|---|
| CVE-2025-48924US | — | Exploit | ||
Uncontrolled Recursion vulnerability in Apache Commons Lang.
This issue affects Apache Commons Lang: Starting with commons-lang:commons-lang 2.0 to 2.6, and, from org.apache.commo… | ||||
references
External citations — patches, advisories, analysis.
- http://www.openwall.com/lists/oss-security/2025/07/11/1WEB
- https://github.com/apache/commons-langPACKAGE
- https://github.com/apache/commons-lang/commit/b424803abdb2bec818e4fbcb251ce031c22aca53WEB
- https://lists.apache.org/thread/bgv0lpswokgol11tloxnjfzdl7yrc1g1WEB
- https://lists.debian.org/debian-lts-announce/2025/08/msg00000.htmlWEB
- https://lists.debian.org/debian-lts-announce/2025/08/msg00026.htmlWEB
- https://lists.debian.org/debian-lts-announce/2025/09/msg00032.htmlWEB
- https://lists.debian.org/debian-lts-announce/2025/09/msg00036.htmlWEB
Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.
Free scan