Keylime registrar is vulnerable to Denial-of-Service attack when updated to version 7.12.0
### Impact The Keylime `registrar` implemented more strict type checking on version 7.12.0. As a result, when updated to version 7.12.0, the `registrar` will not accept the format of the data previously stored in the database by versions >= 7.8.0, raising an exception. This makes the Keylime `registrar` vulnerable to a Denial-of-Service attack in an update scenario, as an attacker could populate the `registrar` database by creating multiple valid agent registrations with different UUIDs while the version is still < 7.12.0. Then, when the Keylime `registrar` is updated to the 7.12.0 version, any query to the database matching any of the entries populated by the attacker will result in failure. ### Patches Users should upgrade to versions >= 7.12.1 ### Workarounds - Remove the registrar database and re-register all agents ### Credit Reported by: Anderson Toshiyuki Sasaki/@ansasaki Patched by: Anderson Toshiyuki Sasaki/@ansasaki
describes (1)
Related CVEs.
| ID | severity | exploitable | ||
|---|---|---|---|---|
| CVE-2025-1057US | — | — | ||
A flaw was found in Keylime, a remote attestation solution, where strict type checking introduced in version 7.12.0 prevents the registrar from reading database entries created by… | ||||
references
External citations — patches, advisories, analysis.
- https://access.redhat.com/security/cve/CVE-2025-1057WEB
- https://bugzilla.redhat.com/show_bug.cgi?id=2343894WEB
- https://github.com/advisories/GHSA-9jxq-5x44-gx23ADVISORY
- https://github.com/keylime/keylimePACKAGE
- https://github.com/keylime/keylime/commit/e08b10d86c3717006774e787542c190e2ba24fc7WEB
- https://github.com/keylime/keylime/security/advisories/GHSA-9jxq-5x44-gx23WEB
- https://nvd.nist.gov/vuln/detail/CVE-2025-1057ADVISORY
- https://pypi.org/project/keylimePACKAGE
Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.
Free scan