Apache Airflow: Ignored Airflow Permission
Apache Airflow, versions 2.8.0 through 2.8.2, has a vulnerability that allows an authenticated user with limited permissions to access resources such as variables, connections, etc from the UI which they do not have permission to access. Users of Apache Airflow are recommended to upgrade to version 2.8.3 or newer to mitigate the risk associated with this vulnerability
01
describes (1)
Related CVEs.
| ID | severity | exploitable | ||
|---|---|---|---|---|
| CVE-2024-28746US | high8.1 | — | ||
Apache Airflow, versions 2.8.0 through 2.8.2, has a vulnerability that allows an authenticated user with limited permissions to access resources such as variables, connections, etc… | ||||
02
references
External citations — patches, advisories, analysis.
- http://www.openwall.com/lists/oss-security/2024/03/13/5WEB
- https://github.com/apache/airflowPACKAGE
- https://github.com/apache/airflow/commit/89e7f3e7bdf2126bbbcd959dc10d65ef92773ccaWEB
- https://github.com/apache/airflow/pull/37881WEB
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2024-46.yamlWEB
- https://lists.apache.org/thread/b4pffc7w7do6qgk4jjbyxvdz5odrvny7WEB
- https://nvd.nist.gov/vuln/detail/CVE-2024-28746ADVISORY
scry
Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.
Free scan