Deserialization of Untrusted Data in Apache Camel CassandraQL
Deserialization of Untrusted Data vulnerability in Apache Camel CassandraQL Component AggregationRepository which is vulnerable to unsafe deserialization. Under specific conditions it is possible to deserialize malicious payload.This issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0. Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1
describes (1)
Related CVEs.
| ID | severity | exploitable | ||
|---|---|---|---|---|
| CVE-2024-23114US | — | — | ||
Deserialization of Untrusted Data vulnerability in Apache Camel CassandraQL Component AggregationRepository which is vulnerable to unsafe deserialization. Under specific conditions… | ||||
references
External citations — patches, advisories, analysis.
- https://camel.apache.org/security/CVE-2024-23114.htmlWEB
- https://github.com/Croway/potential-cassandraWEB
- https://github.com/apache/camelPACKAGE
- https://github.com/apache/camel/pull/12759WEB
- https://github.com/apache/camel/pull/12760WEB
- https://github.com/apache/camel/pull/12761WEB
- https://github.com/apache/camel/pull/12762WEB
- https://github.com/apache/camel/pull/12790WEB
Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.
Free scan