GHSA-vm5m-qmrx-fw8w

ghsaUSosv

Apache Airflow: Bypass permission verification to read code of other dags

view advisory published 2024-01-24Licence: CC-BY-4.0

Apache Airflow, versions before 2.8.1, have a vulnerability that allows an authenticated user to access the source code of a DAG to which they don't have access. This vulnerability is considered low since it requires an authenticated user to exploit it. Users are recommended to upgrade to version 2.8.1, which fixes this issue.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2023-50944USmedium6.5OT elevated—
Apache Airflow, versions before 2.8.1, have a vulnerability that allows an authenticated user to access the source code of a DAG to which they don't have access. This vulnerability…
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan