GHSA-2j39-qcjm-428w

ghsaUSosv

Apache Struts vulnerable to path traversal

view advisory published 2023-12-07Licence: CC-BY-4.0

An attacker can manipulate file upload params to enable paths traversal and under some circumstances this can lead to uploading a malicious file which can be used to perform Remote Code Execution. Users are recommended to upgrade to versions Struts 2.5.33 or Struts 6.3.0.2 or greater to fix this issue.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2023-50164UScritical—
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan