Apache Airflow Cross-Site Request Forgery vulnerability
Apache Airflow, version 2.7.0 through 2.7.3, has a vulnerability that allows an attacker to trigger a DAG in a GET request without CSRF validation. As a result, it was possible for a malicious website opened in the same browser - by the user who also had Airflow UI opened - to trigger the execution of DAGs without the user's consent. Users are advised to upgrade to version 2.8.0 or later which is not affected
01
describes (1)
Related CVEs.
| ID | severity | exploitable | ||
|---|---|---|---|---|
| CVE-2023-49920US | medium6.5 | — | ||
Apache Airflow, version 2.7.0 through 2.7.3, has a vulnerability that allows an attacker to trigger a DAG in a GET request without CSRF validation. As a result, it was possible for… | ||||
02
references
External citations — patches, advisories, analysis.
- http://www.openwall.com/lists/oss-security/2023/12/21/3WEB
- https://github.com/apache/airflowPACKAGE
- https://github.com/apache/airflow/commit/f5d802791fa5f6b13b635f06a1ea2eccc22a9ba7WEB
- https://github.com/apache/airflow/pull/36026WEB
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2023-266.yamlWEB
- https://lists.apache.org/thread/mnwd2vcfw3gms6ft6kl951vfbqrxsnjqWEB
- https://nvd.nist.gov/vuln/detail/CVE-2023-49920ADVISORY
scry
Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.
Free scan