Denial of service via path validation in github.com/quic-go/quic-go
Denial of service via path validation in github.com/quic-go/quic-go
01
describes (1)
Related CVEs.
| ID | severity | exploitable | ||
|---|---|---|---|---|
| CVE-2023-49295US | medium6.5 | — | ||
quic-go is an implementation of the QUIC protocol (RFC 9000, RFC 9001, RFC 9002) in Go. An attacker can cause its peer to run out of memory sending a large number of PATH_CHALLENGE… | ||||
02
references
External citations — patches, advisories, analysis.
- https://github.com/quic-go/quic-go/commit/17fc98c2d81dbe685c19702dc694a9d606ac56dcFIX
- https://github.com/quic-go/quic-go/commit/21609ddfeff93668c7625a85eb09f1541fdad965FIX
- https://github.com/quic-go/quic-go/commit/3a9c18bcd27a01c551ac9bf8bd2b4bded77c189aFIX
- https://github.com/quic-go/quic-go/commit/554d543b50b917369fb1394cc5396d928166cf49FIX
- https://github.com/quic-go/quic-go/commit/6cc3d58935426191296171a6c0d1ee965e10534eFIX
- https://github.com/quic-go/quic-go/commit/9aaefe19fc3dc8c8917cc87e6128bb56d9e9e6ccFIX
- https://github.com/quic-go/quic-go/commit/a0ffa757499913f7be69aa78f573a6aee3430ae4FIX
- https://github.com/quic-go/quic-go/commit/d7aa627ebde91cf799ada2a07443faa9b1e5abb8FIX
scry
Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.
Free scan