Discourse SSRF vulnerability in Embedding
Discourse is an open source platform for community discussion. Prior to version 3.1.3 of the `stable` branch and version 3.2.0.beta3 of the `beta` and `tests-passed` branches, the embedding feature is susceptible to server side request forgery. The issue is patched in version 3.1.3 of the `stable` branch and version 3.2.0.beta3 of the `beta` and `tests-passed` branches. As a workaround, disable the Embedding feature.
01
describes (1)
Related CVEs.
| ID | severity | exploitable | ||
|---|---|---|---|---|
| CVE-2023-47121US | critical9.8 | — | ||
Discourse is an open source platform for community discussion. Prior to version 3.1.3 of the `stable` branch and version 3.2.0.beta3 of the `beta` and `tests-passed` branches, the… | ||||
02
references
External citations — patches, advisories, analysis.
- https://github.com/discourse/discourse/commit/24cca10da731734af4e9748de99a508d586e59f1FIX
- https://github.com/discourse/discourse/commit/5f20748e402223b265e6fee381472c14e2604da6FIX
- https://github.com/discourse/discourse/security/advisories/GHSA-hp24-94qf-8cgcADVISORY
- https://nvd.nist.gov/vuln/detail/CVE-2023-47121WEB
scry
Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.
Free scan