PYSEC-2026-1190

vendorUSosv

Apache Superset Cross-site Scripting vulnerability

view advisory published 2026-07-07Licence: CC-BY-4.0

Improper payload validation and an improper REST API response type, made it possible for an authenticated malicious actor to store malicious code into Chart's metadata, this code could get executed if a user specifically accesses a specific deprecated API endpoint. This issue affects Apache Superset versions prior to 2.1.2.  Users are recommended to upgrade to version 2.1.2, which fixes this issue.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2023-43701USmedium5.4—
Improper payload validation and an improper REST API response type, made it possible for an authenticated malicious actor to store malicious code into Chart's metadata, this code c…
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan