GHSA-cgx2-rrmr-jx43

ghsaUSosv

Apache Airflow vulnerable to sensitive information exposure when users list warnings for all DAGs

view advisory published 2023-10-14Licence: CC-BY-4.0

Apache Airflow, versions prior to 2.7.2, contains a security vulnerability that allows authenticated users of Airflow to list warnings for all DAGs, even if the user had no permission to see those DAGs. It would reveal the dag_ids and the stack-traces of import errors for those DAGs with import errors. Users of Apache Airflow are advised to upgrade to version 2.7.2 or newer to mitigate the risk associated with this vulnerability.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2023-42780USmedium6.5—
Apache Airflow, versions prior to 2.7.2, contains a security vulnerability that allows authenticated users of Airflow to list warnings for all DAGs, even if the user had no permiss…
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan