GHSA-32wr-qqw6-5mfp

ghsaUSosv

Apache Airflow vulnerable to sensitive information exposure

view advisory published 2023-10-14Licence: CC-BY-4.0

Apache Airflow, versions before 2.7.2, has a vulnerability that allows an authorized user with access to read specific DAGs _only_ to read information about task instances in other DAGs. Users of Apache Airflow are advised to upgrade to version 2.7.2 or newer to mitigate the risk associated with this vulnerability.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2023-42663USmedium6.5—
Apache Airflow, versions before 2.7.2, has a vulnerability that allows an authorized user who has access to read specific DAGs only, to read information about task instances in oth…
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan