Apache Superset has Incorrect Default Permissions
Unnecessary read permissions within the Gamma role would allow authenticated users to read configured CSS templates and annotations. This issue affects Apache Superset: before 2.1.2. Users should upgrade to version or above 2.1.2 and run `superset init` to reconstruct the Gamma role or remove `can_read` permission from the mentioned resources.
01
describes (1)
Related CVEs.
| ID | severity | exploitable | ||
|---|---|---|---|---|
| CVE-2023-42501US | medium4.3OT elevated | — | ||
Unnecessary read permissions within the Gamma role would allow authenticated users to read configured CSS templates and annotations.
This issue affects Apache Superset: before 2.1.… | ||||
02
references
External citations — patches, advisories, analysis.
- http://www.openwall.com/lists/oss-security/2023/11/27/3WEB
- https://github.com/advisories/GHSA-vv65-fjfj-4736ADVISORY
- https://github.com/apache/supersetPACKAGE
- https://lists.apache.org/thread/vk1rmrh9kz0chjmc9tk7o3md6zpz4yghWEB
- https://nvd.nist.gov/vuln/detail/CVE-2023-42501ADVISORY
- https://pypi.org/project/apache-supersetPACKAGE
scry
Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.
Free scan