GHSA-g95c-2jgm-hqc6

ghsaUSosv

Fides Webserver Vulnerable to Zip Bomb File Uploads

view advisory published 2023-07-18Licence: CC-BY-4.0

### Impact The Fides webserver is vulnerable to a type of Denial of Service (DoS) attack. Attackers can exploit a weakness in the connector template upload feature to upload a malicious zip bomb file, resulting in resource exhaustion and service unavailability for all users of the Fides webserver. This vulnerability affects Fides versions `2.11.0` through `2.15.1`. Exploitation is limited to users with elevated privileges with the `CONNECTOR_TEMPLATE_REGISTER` scope, which includes root users and users with the owner role. ### Patches The vulnerability has been patched in Fides version `2.16.0`. Users are advised to upgrade to this version or later to secure their systems against this threat. ### Workarounds There is no known workaround to remediate this vulnerability without upgrading. If an attack occurs, the impact can be mitigated by manually or automatically restarting the affected container. ### References More information about this type of vulnerability can be found at the following links: - https://www.bamsoftware.com/hacks/zipbomb/ - https://python-security.readthedocs.io/security.html#archives-and-zip-bomb-cve-2019-9674

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2023-37480USmedium4.9—
Fides is an open-source privacy engineering platform for managing data privacy requests and privacy regulations. The Fides webserver is vulnerable to a type of Denial of Service (D…
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan