Apache RocketMQ may have remote code execution vulnerability when using update configuration function
For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution. Several components of RocketMQ, including NameServer, Broker, and Controller, are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function to execute commands as the system users that RocketMQ is running as. Additionally, an attacker can achieve the same effect by forging the RocketMQ protocol content. To prevent these attacks, users are recommended to upgrade to version 5.1.1 or above for using RocketMQ 5.x or 4.9.6 or above for using RocketMQ 4.x .
describes (1)
Related CVEs.
| ID | severity | exploitable | ||
|---|---|---|---|---|
| CVE-2023-33246US | critical9.8OT critical | KEV | ||
For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution.
Several components of RocketMQ, including NameServer, Broker, and Co… | ||||
references
External citations — patches, advisories, analysis.
- http://packetstormsecurity.com/files/173339/Apache-RocketMQ-5.1.0-Arbitrary-Code-Injection.htmlWEB
- http://www.openwall.com/lists/oss-security/2023/07/12/1WEB
- https://github.com/Malayke/CVE-2023-33246_RocketMQ_RCE_EXPLOITWEB
- https://github.com/apache/rocketmqPACKAGE
- https://github.com/apache/rocketmq/commit/9d411cf04a695e7a3f41036e8377b0aa544d754dWEB
- https://github.com/apache/rocketmq/commit/c3ada731405c5990c36bf58d50b3e61965300703WEB
- https://github.com/jakabakos/CVE-2023-33246_Apache_RocketMQ_RCEWEB
- https://lists.apache.org/thread/1s8j2c8kogthtpv3060yddk03zq0pxypWEB
Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.
Free scan