Spring Boot Security Bypass with Wildcard Pattern Matching on Cloud Foundry
In Spring Boot versions 3.0.0 - 3.0.5, 2.7.0 - 2.7.10, and older unsupported versions, an application that is deployed to Cloud Foundry could be susceptible to a security bypass. Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.6+. 2.7.x users should upgrade to 2.7.11+. Users of older, unsupported versions should upgrade to 3.0.6+ or 2.7.11+.
01
describes (1)
Related CVEs.
| ID | severity | exploitable | ||
|---|---|---|---|---|
| CVE-2023-20873US | critical9.8 | — | ||
In Spring Boot versions 3.0.0 - 3.0.5, 2.7.0 - 2.7.10, and older unsupported versions, an application that is deployed to Cloud Foundry could be susceptible to a security bypass. U… | ||||
02
references
External citations — patches, advisories, analysis.
- https://github.com/spring-projects/spring-bootPACKAGE
- https://github.com/spring-projects/spring-boot/commit/32444fed4b51cc58dc908467f706102d7f0bfc15WEB
- https://github.com/spring-projects/spring-boot/commit/3522714c13b47af03bf42e7f2d5994af568cb1a7WEB
- https://github.com/spring-projects/spring-boot/releases/tag/v2.5.15WEB
- https://github.com/spring-projects/spring-boot/releases/tag/v2.6.15WEB
- https://github.com/spring-projects/spring-boot/releases/tag/v2.7.11WEB
- https://github.com/spring-projects/spring-boot/releases/tag/v3.0.6WEB
- https://nvd.nist.gov/vuln/detail/CVE-2023-20873ADVISORY
scry
Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.
Free scan