GHSA-3gfj-fxx4-f22w

ghsaUSosv

OpenFGA Authorization Bypass

view advisory published 2022-11-08Licence: CC-BY-4.0

### Overview During our internal security assessment, it was discovered that OpenFGA versions v0.2.4 and prior are vulnerable to authorization bypass under certain conditions. ### Am I Affected? You are affected by this vulnerability if you are using `openfga/openfga` version v0.2.4 or prior, and have tuples where the `user` field is set to a `userset` e.g. `folder:test#owner`, and the tuple's relation is used on the right-hand side of a `from` statement. ### How to fix that? Upgrade to version 0.2.5. ### Backward Compatibility This update is not backward compatible. Any tuples where the `user` field is set to a `userset`, and the tuple's relation is used on the right-hand side of a `from` statement have to be rewritten.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2022-39352UScritical9.8OT elevated—
OpenFGA is a high-performance authorization/permission engine inspired by Google Zanzibar. Versions prior to 0.2.5 are vulnerable to authorization bypass under certain conditions.…
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan