opensearch-ruby 2.x before 2.0.2 vulnerable to unsafe YAML deserialization
### Impact A YAML deserialization in opensearch-ruby 2.0.0 can lead to unsafe deserialization using YAML.load if the response is of type YAML. ### Patches The problem has been patched in opensearch-ruby gem version 2.0.2. ### Workarounds No viable workaround. Please upgrade to 2.0.2 ### References https://github.com/opensearch-project/opensearch-ruby/pull/77 https://staaldraad.github.io/post/2021-01-09-universal-rce-ruby-yaml-load-updated/ ### For more information If you have any questions or comments about this advisory: * Open an issue in [opensearch-ruby](https://github.com/opensearch-project/opensearch-ruby)
describes (1)
Related CVEs.
| ID | severity | exploitable | ||
|---|---|---|---|---|
| CVE-2022-31115US | high8.8 | — | ||
opensearch-ruby is a community-driven, open source fork of elasticsearch-ruby. In versions prior to 2.0.1 the ruby `YAML.load` function was used instead of `YAML.safe_load`. As a r… | ||||
references
External citations — patches, advisories, analysis.
- https://github.com/opensearch-project/opensearch-rubyPACKAGE
- https://github.com/opensearch-project/opensearch-ruby/commit/d74a98b45c037671e8819fa87f6a6423458ab08aWEB
- https://github.com/opensearch-project/opensearch-ruby/compare/v2.0.1...v2.0.2WEB
- https://github.com/opensearch-project/opensearch-ruby/pull/77WEB
- https://github.com/opensearch-project/opensearch-ruby/security/advisories/GHSA-977c-63xq-cgw3WEB
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/opensearch-ruby/CVE-2022-31115.ymlWEB
- https://nvd.nist.gov/vuln/detail/CVE-2022-31115ADVISORY
- https://staaldraad.github.io/post/2021-01-09-universal-rce-ruby-yaml-load-updatedWEB
Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.
Free scan