Possible shell escape sequence injection vulnerability in Rack
There is a possible shell escape sequence injection vulnerability in the Lint and CommonLogger components of Rack. This vulnerability has been assigned the CVE identifier CVE-2022-30123. Versions Affected: All. Not affected: None Fixed Versions: 2.0.9.1, 2.1.4.1, 2.2.3.1 ## Impact Carefully crafted requests can cause shell escape sequences to be written to the terminal via Rack's Lint middleware and CommonLogger middleware. These escape sequences can be leveraged to possibly execute commands in the victim's terminal. Impacted applications will have either of these middleware installed, and vulnerable apps may have something like this: ``` use Rack::Lint ``` Or ``` use Rack::CommonLogger ``` All users running an affected release should either upgrade or use one of the workarounds immediately. ## Workarounds Remove these middleware from your application
describes (1)
Related CVEs.
| ID | severity | exploitable | ||
|---|---|---|---|---|
| CVE-2022-30123US | critical10.0 | — | ||
A sequence injection vulnerability exists in Rack <2.0.9.1, <2.1.4.1 and <2.2.3.1 which could allow is a possible shell escape in the Lint and CommonLogger components of Rack. | ||||
references
External citations — patches, advisories, analysis.
- https://discuss.rubyonrails.org/t/cve-2022-30123-possible-shell-escape-sequence-injection-vulnerability-in-rack/80728WEB
- https://github.com/rack/rackPACKAGE
- https://github.com/rack/rack/commit/b426cc224908ec6ed6eb8729325392b048215d88WEB
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rack/CVE-2022-30123.ymlWEB
- https://groups.google.com/g/ruby-security-ann/c/LWB10kWzag8WEB
- https://nvd.nist.gov/vuln/detail/CVE-2022-30123ADVISORY
- https://security.gentoo.org/glsa/202310-18WEB
- https://security.netapp.com/advisory/ntap-20231208-0011WEB
Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.
Free scan