GHSA-w5m2-299g-rff5

ghsaUSosv

Page Compare Reflected Cross-site Scripting (XSS) vulnerability

view advisory published 2022-04-26Licence: CC-BY-4.0

### Impact ACS Commons version 5.1.x (and earlier) suffers from a Reflected Cross-site Scripting (XSS) vulnerability in `/apps/acs-commons/content/page-compare.html` endpoint via the `a` and `b` GET parameters. User input submitted via these parameters is not validated or sanitized. An attacker must provide a link to someone with access to AEM Author, and could potentially exploit this vulnerability to inject malicious JavaScript content into vulnerable form fields and execute it within the context of the victim's browser. The exploitation of this issue requires user interaction in order to be successful. ### Patches This issue has been resolved in 5.2.0. ### Workarounds None ### References N/A ### For more information If you have any questions or comments about this advisory open an issue in acs-aem-commons. ### Credit This issue was discovered and reported by Black Lantern Security. https://hackerone.com/reports/1466020

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2022-28820USmedium4.3—
ACS Commons version 5.1.x (and earlier) suffers from a Reflected Cross-site Scripting (XSS) vulnerability in /apps/acs-commons/content/page-compare.html endpoint via the a and b GE…
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan