Mautic has insufficient authentication in upgrade flow
### Impact Mautic allows you to update the application via an upgrade script. The upgrade logic isn't shielded off correctly, which may lead to vulnerable situation. This vulnerability is mitigated by the fact that Mautic needs to be installed in a certain way to be vulnerable ### Patches Please upgrade to 4.4.1 or 5.1.1 or later. ### Workarounds None. ### For more information If you have any questions or comments about this advisory: * Email us at [security@mautic.org](mailto:security@mautic.org)
describes (1)
Related CVEs.
| ID | severity | exploitable | ||
|---|---|---|---|---|
| CVE-2022-25770US | high7.5OT elevated | — | ||
Mautic allows you to update the application via an upgrade script.
The upgrade logic isn't shielded off correctly, which may lead to vulnerable situation.
This vulnerability is m… | ||||
references
External citations — patches, advisories, analysis.
- https://github.com/mautic/mauticPACKAGE
- https://github.com/mautic/mautic/commit/73b18e9a434a28e528fe0e3d03620e7367bdcdcaWEB
- https://github.com/mautic/mautic/commit/aee7bfb7510a83acf178a7f02da9661c040e9abfWEB
- https://github.com/mautic/mautic/security/advisories/GHSA-qf6m-6m4g-rmrcWEB
- https://nvd.nist.gov/vuln/detail/CVE-2022-25770ADVISORY
Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.
Free scan