GHSA-xjp4-6w75-qrj7

ghsaUSosv

Remote CLI Command Execution Vulnerability in CodeIgniter4

view advisory published 2022-03-01Licence: CC-BY-4.0

### Impact This vulnerability allows attackers to execute CLI routes via HTTP request. ### Patches Upgrade to v4.1.9 or later. ### Workarounds None. ### For more information If you have any questions or comments about this advisory: * Open an issue in [codeigniter4/CodeIgniter4](https://github.com/codeigniter4/CodeIgniter4/issues) * Email us at [SECURITY.md](https://github.com/codeigniter4/CodeIgniter4/blob/develop/SECURITY.md)

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2022-24711UScritical9.8—
CodeIgniter4 is the 4.x branch of CodeIgniter, a PHP full-stack web framework. Prior to version 4.1.9, an improper input validation vulnerability allows attackers to execute CLI ro…
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan