GHSA-mm33-5vfq-3mm3

ghsaUSosv

Cross-site Scripting Vulnerability in Action Pack

view advisory published 2022-04-27Licence: CC-BY-4.0

There is a possible XSS vulnerability in Rails / Action Pack. This vulnerability has been assigned the CVE identifier CVE-2022-22577. Versions Affected: >= 5.2.0 Not affected: < 5.2.0 Fixed Versions: 7.0.2.4, 6.1.5.1, 6.0.4.8, 5.2.7.1 ## Impact CSP headers were only sent along with responses that Rails considered as "HTML" responses. This left API requests without CSP headers, which could possibly expose users to XSS attacks. ## Releases The FIXED releases are available at the normal locations. ## Workarounds Set a CSP for your API responses manually.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2022-22577USmedium6.1—
An XSS Vulnerability in Action Pack >= 5.2.0 and < 5.2.0 that could allow an attacker to bypass CSP for non HTML like responses.
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan