Possible code injection vulnerability in Rails / Active Storage
The Active Storage module of Rails starting with version 5.2.0 is possibly vulnerable to code injection. This issue was patched in versions 5.2.6.3, 6.0.4.7, 6.1.4.7, and 7.0.2.3. To work around this issue, applications should implement a strict allow-list on accepted transformation methods or arguments. Additionally, a strict ImageMagick security policy will help mitigate this issue.
01
describes (1)
Related CVEs.
| ID | severity | exploitable | ||
|---|---|---|---|---|
| CVE-2022-21831US | critical9.8 | Exploit | ||
A code injection vulnerability exists in the Active Storage >= v5.2.0 that could allow an attacker to execute code via image_processing arguments. | ||||
02
references
External citations — patches, advisories, analysis.
- https://github.com/advisories/GHSA-w749-p3v6-hccqADVISORY
- https://github.com/rails/railsPACKAGE
- https://github.com/rails/rails/commit/0a72f7d670e9aa77a0bb8584cb1411ddabb7546eWEB
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/activestorage/CVE-2022-21831.ymlWEB
- https://groups.google.com/g/rubyonrails-security/c/n-p-W1yxatIWEB
- https://lists.debian.org/debian-lts-announce/2022/09/msg00002.htmlWEB
- https://nvd.nist.gov/vuln/detail/CVE-2022-21831ADVISORY
- https://rubysec.com/advisories/CVE-2022-21831WEB
scry
Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.
Free scan