GHSA-w6jr-wj64-mc9x

ghsaUSosv

Deserialization of Untrusted Data in Codeigniter4

view advisory published 2022-01-06Licence: CC-BY-4.0

### Impact Deserialization of Untrusted Data was found in the `old()` function in CodeIgniter4. Remote attackers may inject auto-loadable arbitrary objects with this vulnerability, and possibly execute existing PHP code on the server. We are aware of a working exploit, which can lead to SQL injection. ### Patches Upgrade to v4.1.6 or later. ### Workarounds Do not use: - `old()` and form_helper - `RedirectResponse::withInput()` and `redirect()->withInput()` ### References - [PHP Object Injection | OWASP](https://owasp.org/www-community/vulnerabilities/PHP_Object_Injection) ### For more information If you have any questions or comments about this advisory: * Open an issue in [codeigniter4/CodeIgniter4](https://github.com/codeigniter4/CodeIgniter4/issues) * Email us at [SECURITY.md](https://github.com/codeigniter4/CodeIgniter4/blob/develop/SECURITY.md)

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2022-21647UScritical9.8—
CodeIgniter is an open source PHP full-stack web framework. Deserialization of Untrusted Data was found in the `old()` function in CodeIgniter4. Remote attackers may inject auto-lo…
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan