Insufficiently Protected Credentials in Apache Superset
Apache Superset up to and including 1.3.2 allowed for registered database connections password leak for authenticated users. This information could be accessed in a non-trivial way. Users should upgrade to Apache Superset 1.4.0 or higher.
01
describes (1)
Related CVEs.
| ID | severity | exploitable | ||
|---|---|---|---|---|
| CVE-2021-44451US | medium6.5 | — | ||
Apache Superset up to and including 1.3.2 allowed for registered database connections password leak for authenticated users. This information could be accessed in a non-trivial way… | ||||
02
references
External citations — patches, advisories, analysis.
- https://github.com/advisories/GHSA-hhm3-48h2-597vADVISORY
- https://github.com/apache/supersetPACKAGE
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-superset/PYSEC-2022-36.yamlWEB
- https://lists.apache.org/thread/xww1pccs2ckb5506wrf1v4lmxg198vkbWEB
- https://nvd.nist.gov/vuln/detail/CVE-2021-44451ADVISORY
scry
Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.
Free scan