GHSA-94xh-2fmc-xf5j

ghsaUSosv

systeminformation command injection vulnerability

view advisory published 2020-10-27Licence: CC-BY-4.0

### Impact command injection vulnerability ### Patches Problem was fixed with a shell string sanitation fix. Please upgrade to version >= 4.27.11 ### Workarounds If you cannot upgrade, be sure to check or sanitize service parameter strings that are passed to si.inetChecksite() ### References _Are there any links users can visit to find out more?_ ### For more information If you have any questions or comments about this advisory: * Open an issue in [systeminformation](https://github.com/sebhildebrandt/systeminformation/issues/new?template=bug_report.md)

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2020-7752USmedium6.5—
This affects the package systeminformation before 4.27.11. This package is vulnerable to Command Injection. The attacker can concatenate curl's parameters to overwrite Javascript f…
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan