Cross-Site Scripting in jquery
Versions of `jquery` prior to 1.9.0 are vulnerable to Cross-Site Scripting. The load method fails to recognize and remove `<script>` HTML tags that contain a whitespace character, i.e: `</script >`, which results in the enclosed script logic to be executed. This allows attackers to execute arbitrary JavaScript in a victim's browser. ## Recommendation Upgrade to version 1.9.0 or later.
01
describes (1)
Related CVEs.
| ID | severity | exploitable | ||
|---|---|---|---|---|
| CVE-2020-7656US | medium6.1 | Exploit | ||
jquery prior to 1.9.0 allows Cross-site Scripting attacks via the load method. The load method fails to recognize and remove "<script>" HTML tags that contain a whitespace characte… | ||||
02
references
External citations — patches, advisories, analysis.
- https://github.com/jquery/jqueryPACKAGE
- https://github.com/jquery/jquery/blob/9e6393b0bcb52b15313f88141d0bd7dd54227426/src/ajax.js#L203WEB
- https://github.com/jquery/jquery/commit/05531fc4080ae24070930d15ae0cea7ae056457dWEB
- https://github.com/jquery/jquery/commit/606b863edaff29035960e4d813b45d63b8d92876WEB
- https://github.com/rails/jquery-rails/blob/master/CHANGELOG.md#220-19-january-2013WEB
- https://github.com/rails/jquery-rails/blob/v2.1.4/vendor/assets/javascripts/jquery.js#L7481WEB
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/jquery-rails/CVE-2020-7656.ymlWEB
- https://nvd.nist.gov/vuln/detail/CVE-2020-7656ADVISORY
scry
Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.
Free scan