GHSA-qgfr-5hqp-vrw9

ghsaUSosv

Path Traversal in decompress

view advisory published 2020-09-03Licence: CC-BY-4.0

Versions of `decompress` prior to 4.2.1 are vulnerable to Arbitrary File Write. The package fails to prevent extraction of files with relative paths, allowing attackers to write to any folder in the system by including filenames containing`../`. ## Recommendation Upgrade to version 4.2.1 or later.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2020-12265UScritical9.8—
The decompress package before 4.2.1 for Node.js is vulnerable to Arbitrary File Write via ../ in an archive member, when a symlink is used, because of Directory Traversal.
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan