Potential XSS vulnerability in jQuery
In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.
01
describes (1)
Related CVEs.
| ID | severity | exploitable | ||
|---|---|---|---|---|
| CVE-2020-11023US | medium6.1OT critical | KEV | ||
In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's… | ||||
02
references
External citations — patches, advisories, analysis.
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00067.htmlWEB
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00085.htmlWEB
- http://lists.opensuse.org/opensuse-security-announce/2020-11/msg00039.htmlADVISORY
- http://packetstormsecurity.com/files/162160/jQuery-1.0.3-Cross-Site-Scripting.htmlADVISORY
- https://blog.jquery.com/2020/04/10/jquery-3-5-0-releasedADVISORY
- https://github.com/github/advisory-database/blob/99afa6fdeaf5d1d23e1021ff915a5e5dbc82c1f1/advisories/github-reviewed/2020/04/GHSA-jpcq-cgw6-v4j6/GHSA-jpcq-cgw6-v4j6.json#L20-L37ADVISORY
- https://github.com/jquery/jquery/security/advisories/GHSA-jpcq-cgw6-v4j6ADVISORY
- https://jquery.com/upgrade-guide/3.5/ADVISORY
scry
Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.
Free scan