Bootstrap Vulnerable to Cross-Site Scripting
Versions of `bootstrap` prior to 3.4.1 for 3.x and 4.3.1 for 4.x are vulnerable to Cross-Site Scripting (XSS). The `data-template` attribute of the tooltip and popover plugins lacks input sanitization and may allow attacker to execute arbitrary JavaScript. ## Recommendation For `bootstrap` 4.x upgrade to 4.3.1 or later. For `bootstrap` 3.x upgrade to 3.4.1 or later.
01
describes (1)
Related CVEs.
| ID | severity | exploitable | ||
|---|---|---|---|---|
| CVE-2019-8331US | medium6.1 | Exploit | ||
In Bootstrap before 3.4.1 and 4.3.x before 4.3.1, XSS is possible in the tooltip or popover data-template attribute. | ||||
02
references
External citations — patches, advisories, analysis.
- http://packetstormsecurity.com/files/156743/OctoberCMS-Insecure-Dependencies.htmlWEB
- http://seclists.org/fulldisclosure/2019/May/10WEB
- http://seclists.org/fulldisclosure/2019/May/11WEB
- http://seclists.org/fulldisclosure/2019/May/13WEB
- https://access.redhat.com/errata/RHSA-2019:1456WEB
- https://access.redhat.com/errata/RHSA-2019:3023WEB
- https://access.redhat.com/errata/RHSA-2019:3024WEB
- https://blog.getbootstrap.com/2019/02/13/bootstrap-4-3-1-and-3-4-1WEB
scry
Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.
Free scan